Uploading only audio mp4 fails

Steps to reproduce

Steps to reproduce:
1. Upload mp4 without video track but with audio track

Actual Results:
Publish engage fails with unmet criteria.

Expected Results:
Workflow sucessfully completes.

I tested with todays r/2.0.x with the minimal workflow in the old admin ui. My mp4 has no video track but one AAC audio track.

Activity

Show:
Lukas Rohner
May 28, 2015, 11:56 AM

Sorry I mixed up something here, your pull request 521 looks good to me.

Lukas Rohner
May 28, 2015, 9:27 AM

I don't think we should change the flavor of an audio track. The issue is as far I can see only a workflow issue.

Adam McKenzie
May 28, 2015, 2:39 AM

I think I have found the issue and solved it in this pull request:
https://bitbucket.org/opencast-community/matterhorn/pull-request/521/mh-10834-audio-only-uploads-fail-to/diff

The problem was that the audio only track was given the flavor presenter-audio/source even if the presenter/source track was not present. I have fixed it by assigning the audio track the presenter/source flavor if there are no other present tracks.

Lars Kiesow
May 19, 2015, 2:48 PM

, this should be fixed with your pull request
https://bitbucket.org/opencast-community/matterhorn/pull-request/500/

Lars Kiesow
May 15, 2015, 2:35 PM

The reason for this failing is that the new admin-ui does not distinguish between multi-file-upload and single file upload.
The "audio-only" upload field really is only meant for "an additional audio stream to mux into the video".

If uploaded as presentation/source, the workflow fails as well.

If uploaded as presenter/source, the workflow runs through.

Fixed and reviewed
Your pinned fields
Click on the next to a field label to start pinning.

Assignee

Adam McKenzie

Reporter

Michael Stypa

Severity

Non Functioning

Tags (folksonomy)