Theodul player : Videos not playable on IE10

Steps to reproduce

Steps to reproduce:
1. Load a video using IE10
2. Video does not load and errors in console.

Actual Results:

Video does not play back

Expected Results:

Video should load and playback media

Workaround (if any):

Using FF, chrome or IE11

Activity

Show:
Edmore Moyo
July 13, 2015, 9:52 PM

Apache seems to be serving the incorrect content-type:

➜ ~ curl -I http://mediadev.cet.uct.ac.za/static/engage-player/938be5fd-b10c-474f-b8b6-f34f1b78627d/ec4bd0e9-67f0-45ab-9942-f32faf5d5de7/presenter_f0aed304_8cdc_4fee_ad43_6d88e5eb0a76.mp4
HTTP/1.1 200 OK
Date: Mon, 13 Jul 2015 11:39:46 GMT
Server: Apache/2.2.12 (Linux/SUSE)
Last-Modified: Fri, 24 Apr 2015 11:10:46 GMT
ETag: "eea9b6-5147672ac37ca"
Accept-Ranges: bytes
Content-Length: 15641014
Content-Type: text/plain

fixable by using AddType directive.

Rüdiger Rolf
April 11, 2016, 7:23 PM

By 01.01.2016 Microsoft dropped the support for all Internet Explorer version < 11, as this is the latest version for Windows 7, 8.1 and 10. So the question would be if we still want/need to support older versions of IE? I am aware that some IT departments are very slow in updating their computers, but why should we support software that even by the definition of Microsoft has security issues.

The general problem is that we use a Javascript "Set" that is in the language's standard but was not implemented for IE 10.

Former user
April 25, 2016, 11:34 PM

Merged #875 as 8720522

Fixed and reviewed

Assignee

Rüdiger Rolf

Reporter

Edmore Moyo

Severity

Incorrectly Functioning Without Workaround

Tags (folksonomy)

None

Components

Fix versions

Affects versions

Priority

Major