Uploaded image for project: 'Opencast'
  1. MH-11227

User-Utils PUT {username}.json not working correctly

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed and reviewed
    • Affects versions: 2.1.0
    • Fix versions: 2.1.0
    • Components: RESTful Interfaces
    • Labels:
      None
    • Severity:
      Incorrectly Functioning Without Workaround
    • Steps to reproduce:
      Hide
      The PUT endpoint has the same problem as the POST endpoint:

       - No value checks
       - May throw exeptions

      But there are more problems:

       - It will not necessary completely replace a user as it should as roles might not be overwritten (behavea like PATCH in that sense)
       - If a specified user does not exist yet, the entity will be created
      Show
      The PUT endpoint has the same problem as the POST endpoint:  - No value checks  - May throw exeptions But there are more problems:  - It will not necessary completely replace a user as it should as roles might not be overwritten (behavea like PATCH in that sense)  - If a specified user does not exist yet, the entity will be created

      TestRail: Results

        Attachments

          Activity

            People

            • Assignee:
              lkiesow Lars Kiesow
              Reporter:
              lkiesow Lars Kiesow
            • Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                TestRail: Cases