Uploaded image for project: 'Opencast'
  1. MH-11639

Media module login form has poor usability and bugs

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed and reviewed
    • Affects Version/s: 2.2.0
    • Fix Version/s: 2.2.0
    • Component/s: Engage User Interface
    • Labels:
      None
    • Severity:
      Usability Issue
    • Steps to reproduce:
      Hide
      Steps to reproduce:
      1. Publish a video without allowing anonymous read access
      2. Go to the media module
      3. Attempt to log in
       
       Actual Results:
       -With incorrect credentials there is no warning that they are incorrect, and the login prompt closes. The user is not logged in, so nothing changes
       -With correct credentials things work as expected
       
      Other issues:
      -Username is not focussed, requiring manual click before user input
      -Hitting enter does not submit the form





      Show
      Steps to reproduce: 1. Publish a video without allowing anonymous read access 2. Go to the media module 3. Attempt to log in    Actual Results:  -With incorrect credentials there is no warning that they are incorrect, and the login prompt closes. The user is not logged in, so nothing changes  -With correct credentials things work as expected   Other issues: -Username is not focussed, requiring manual click before user input -Hitting enter does not submit the form

      TestRail: Results

        Attachments

          Activity

            People

            • Assignee:
              lkiesow Lars Kiesow
              Reporter:
              greg_logan Greg Logan
            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                TestRail: Cases