Support latest released versions of mysql (5.7+) and mariadb

Description

Opencast 2.2.0 explicitly does not support mysql 5.7 or mariab 10.1 as per

https://docs.opencast.org/r/2.2.x/admin/configuration/database/

"Notice: Opencast 2.2 is not compatible with MySQL 5.7 (and probably MariaDB 10.1). Please use MariaDB 10.0 or MySQL 5.5 or 5.6."

Opencast should aim to support the current Generally Available release of its supposed databases (for MySQL, currently 5.7.13).

Activity

Show:
Stephen Marquard
October 5, 2019, 9:51 AM

Obsolete; 8.x docs no longer include version notices.

Stephen Marquard
June 28, 2017, 3:24 PM

We need to update this page:

https://docs.opencast.org/r/3.x/admin/configuration/database/

which refers to Opencast 2.2

Stephen Marquard
June 28, 2017, 11:30 AM

I had problems running 3.x with mysql 5.7.13, but 5.7.18 seems fine (with mysql connector version 5.1.42).

Stephen Marquard
June 21, 2016, 9:08 AM

From: RĂ¼diger Rolf rrolf@uni-osnabrueck.de
Sent: 21 June 2016 09:49 AM
To: matterhorn@opencast.org
Subject: Re: [Matterhorn] MySQLIntegrityConstraintViolationException from AclScanner in 2.2

Hi Stephen,

I had several aries blueprint errors in my tests with MySQL 5.7 that I already knew from my tries to upgrade the mysql connector. These let to several other issues with the database. I had not seen these in 5.6, but I only did a very quick check with this version.

The connector is not in karaf itself, but several dependencies for JPA etc. The libraries for JPA seem to be a very fragile construction that seem not to be upgradeable separately. So it was a very simply try and error to find the latest mysql-connector version that still works reliable with our current setup.

...

Fixed and reviewed

Assignee

Unassigned

Reporter

Stephen Marquard