Non-Latin characters show as ??? in several places.

Steps to reproduce

Steps to reproduce:
1.Create some events with Chinese title, their titles show normally in /admin-ng/index.html
2.But these Chinese titles show as ??? in Event detail->Workflows-Details, the Series UI on /engage/ui/index.html, ffmpeg-generated cover-image, REST invoking returning results ( i.e, Pumukit 2 integration).

Expected Results:
They should show normally.

Workaround (if any):
I guess that's because non-uniform encoding between MySQL database and Java code.

Activity

Show:
Stephen Marquard
September 23, 2017, 10:49 AM

for the workflow config properties - occurs with both Galicaster 2.x and pyca so don't think it's CA-specific.

Stephen Marquard
September 23, 2017, 10:42 AM

I can see event.title in the workflow configuration looks wrong, from a Galicaster recording. It may be wrong before it gets to the admin UI (e.g. an ingest or not handled correctly on CA), because if you look at e.g.

/admin-ng/event/345c0353-395a-45d6-b6c0-ccf8ef306b7d/workflows/2287.json

then title is wrong, but configuration>event.title. is mis-encoded. Not sure if it's a Galicaster issue or an ingest issue, or a workflow issue. It doesn't seem like it's an Admin UI issue.

/engage/ui/index.html also looks fine to me.

For the REST endpoints, it's worth nothing that we return application/json without charset which is correct according to the JSON spec, but currently Chrome doesn't display these properly in unicode (https://bugs.chromium.org/p/chromium/issues/detail?id=438464) if you look at the REST json output directly; Firefox does the right thing.

I haven't tested the cover image generation but if that's an issue it should have a separate JIRA.

Lars Kiesow
September 23, 2017, 10:29 AM
Edited

Tried but could not reproduce this on https://develop.opencast.org
I tried with series and event named 測試題目 with no problem in both Chrome and Firefox.
If you have a way of reproducing this issue, please feel free to re-open this ticket.

Stephen Marquard
September 23, 2017, 9:08 AM

Opencast is an open source project, so there is no single person or organization who is responsible for solving this problem. You can help by:

1. Testing to see if you can reproduce the problem on https://develop.opencast.org/ (login admin/opencast) (and update this JIRA with the results)

2. Attach screenshots of where the problem appears

3. If the problem is very important to you, you can contribute a fix, or you can contract developers to fix it for you.

Vincent
September 22, 2017, 10:51 PM

Will you please solve this problem in next release instead of postponing and postponing ?

Cannot Reproduce
Your pinned fields
Click on the next to a field label to start pinning.

Assignee

Lars Kiesow

Reporter

fish free

Severity

Non Functioning