Opencast build fails when system timezone is set to PDT (Pacific Daylight Time)

Steps to reproduce

After checking out the git repo for release 2.2.2 on a freshly installed CentOS 7 system, I found I couldn't get opencast to compile. It would always error out during the 'grunt' phase in matterhorn-admin-ui-ng.

I tried running npm from the matterhorn-admin-ui-ng modules directory for a better error report (attached). When I noticed the date checks were failing, I tried changing the computer to UTC time (rm /etc/localtime, ln -s /usr/share/zoneinfo/UTC /etc/localtime). This allowed the build to succeed.

Steps to reproduce:
1. Set timezone to PDT (I use '/usr/share/zoneinfo/America/Los_Angeles').
2. Checkout the 2.2.2 branch via git.
3. Install all dependencies.
4. mvn clean install

I also tried this on the 2.2.3-rc1 branch and got the same error.

Actual Results:
[ERROR] Failed to execute goal com.github.eirslett:frontend-maven-plugin:0.0.23:npm (frontend build) on project matterhorn-admin-ui-ng: Failed to run task: 'npm run build --no-color --skipTests=false --color=false' failed. (error code 1) -> [Help 1]

Expected Results:
Successful build

Workaround (if any):
Change the system clock to UTC.

Activity

Show:
Lars Kiesow
December 22, 2016, 4:09 PM

Greg, iirc, you had a look at an error like this. Do you know if it is fixed?

Greg Logan
April 20, 2017, 7:16 PM

Hi Mikey,

I can reproduce this with 2.2.x, but not with a 2.3.x release, so this has been fixed in a later release.

Assignee

Greg Logan

Reporter

Mikey Orr

Severity

Build Error

Tags (folksonomy)

None

Fix versions

Affects versions

Priority

Major
Configure