Uploaded image for project: 'Opencast'
  1. MH-12264

Roles and templates are not correctly displayed when creating a series

    Details

    • Severity:
      Incorrectly Functioning Without Workaround
    • Steps to reproduce:
      Hide
      Steps to reproduce:
      1. Login as a non-admin user with Admin UI privileged.
      2. Open the "create series" wizard in the admin UI
      3. Fill in the information and move forward until the "Access Policy" tab
      4. Select one of the templates available
      5. In the drop-down menus below, type a custom role (i.e. not internal; for instance, one that matches a pattern in custom.properties) in the drop-down menus below.
      6. Select also a internal role in another line (ROLE_ANONYMOUS, for instance)
      7. Go forward to the next tab and come back again

       Actual Results:
      1. Templates can be selected, but they cause no effect in the roles below
      2. If a template is selected, it can not be deleted again (such as with the "Branding" drop-down menu in the next tab)
      3. The user's own role (e.g. ROLE_USER_<USERNAME>) can not be selected in the menu.
      4. After returning to the tab, the custom roles are not displayed. The boxes display "Select an option", as if no role was selected. However the roles are currently display in the summary tab at the end of the wizard. The internal roles are displayed properly.
      5. If we close the wizard and try to start over, we still see the information already provided. We must reload the page in order to clear all the information.

       Expected Results:
      1. Templates should display the roles properly.
      2. Role names should also be correctly displayed.
       
       Workaround (if any):
       





      Show
      Steps to reproduce: 1. Login as a non-admin user with Admin UI privileged. 2. Open the "create series" wizard in the admin UI 3. Fill in the information and move forward until the "Access Policy" tab 4. Select one of the templates available 5. In the drop-down menus below, type a custom role (i.e. not internal; for instance, one that matches a pattern in custom.properties) in the drop-down menus below. 6. Select also a internal role in another line (ROLE_ANONYMOUS, for instance) 7. Go forward to the next tab and come back again  Actual Results: 1. Templates can be selected, but they cause no effect in the roles below 2. If a template is selected, it can not be deleted again (such as with the "Branding" drop-down menu in the next tab) 3. The user's own role (e.g. ROLE_USER_<USERNAME>) can not be selected in the menu. 4. After returning to the tab, the custom roles are not displayed. The boxes display "Select an option", as if no role was selected. However the roles are currently display in the summary tab at the end of the wizard. The internal roles are displayed properly. 5. If we close the wizard and try to start over, we still see the information already provided. We must reload the page in order to clear all the information.  Expected Results: 1. Templates should display the roles properly. 2. Role names should also be correctly displayed.    Workaround (if any):  

      TestRail: Results

        Attachments

        1. screenshot-1.png
          62 kB
        2. screenshot-2.png
          61 kB
        3. screenshot-3.png
          45 kB
        4. screenshot-4.png
          61 kB
        5. screenshot-5.png
          61 kB

          Activity

            People

            • Assignee:
              Corné Oosthuizen
              Reporter:
              Rubén Pérez
            • Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:

                TestRail: Cases

                  TestRail: Runs