Uploaded image for project: 'Opencast'
  1. MH-13472

Permissions for /play/ missing in mh_default_org

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed and reviewed
    • Affects versions: 7.0
    • Fix versions: None
    • Components: Engage User Interface
    • Labels:
      None
    • Severity:
      Incorrectly Functioning With Workaround
    • Steps to reproduce:
      Hide
      Looks like we need:

        <sec:http pattern="/play/*" security="none" />

      in etc/security/mh_default_org.xml for non-admin users to be able to play videos.


      Steps to reproduce:
      1. Publish a video with an ACL that allows a non-admin user to play it
      2. Attempt to play video as the non-admin user
       
       Actual Results:

      jetty permission denied
       
       Expected Results:

      Video should play.
        
      Show
      Looks like we need:   <sec:http pattern="/play/*" security="none" /> in etc/security/mh_default_org.xml for non-admin users to be able to play videos. Steps to reproduce: 1. Publish a video with an ACL that allows a non-admin user to play it 2. Attempt to play video as the non-admin user    Actual Results: jetty permission denied    Expected Results: Video should play.   

      TestRail: Results

        Attachments

          Issue links

            Activity

              People

              • Assignee:
                lkiesow Lars Kiesow
                Reporter:
                smarquard Stephen Marquard
              • Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  TestRail: Cases