Capture Agent with webcam ( Logitech Pro HD C910) crashes randomly

Steps to reproduce

Affects RC2.

Running Ubuntu 10.10 64 bit server most recordings crash matterhorn. Same JVM and Memory settings on a 32 bit equivalent system work fine. All recordings whether manually started or scheduled will crash. felix logs show nothing. The following GStreamer errors get printed on stdout.

Activity

Show:
Christopher Brooks
April 14, 2011, 2:37 AM

Adam,

Check out http://gstreamer.freedesktop.org/data/doc/gstreamer/head/gstreamer/html/GstPipeline.html

gst_pipeline_set_auto_flush_bus ()

Might be interesting

Christopher Brooks
May 25, 2011, 10:59 PM

This appears to be an issue with that webcam and/or with framesizes for webcams using 1080p. It does not appear to be a matterhorn specific issue.

Ramki
July 27, 2011, 1:00 PM

We are getting this issue with Bluecherry card...We have stuck to the reference hardware and built the agent. We are not using a webcam. We used to get green videos and resolved the issue with a custom pipeline.as referred in

http://opencast.jira.com/wiki/display/MH/FAQ+%28Trunk%29

When we were using standard PC for testing the CA with the same card and setting , we used to get a duration issue meaning, for a 5 minute recording we used to produce about half the time..Now with the new CA hardware we are unable to test due to this error.

We are using 1.1.10282

please find below the error..the agent crashes.

(unknown:1909): GStreamer-CRITICAL **:
Trying to dispose element capsfilter3, but it is in PLAYING instead of the NULL state.
You need to explicitly set elements to the NULL state before
dropping the final reference, to allow them to clean up.
This problem may also be caused by a refcounting bug in the
application or some element.

(unknown:1909): GStreamer-CRITICAL **:
Trying to dispose element queue7, but it is in PLAYING instead of the NULL state.
You need to explicitly set elements to the NULL state before
dropping the final reference, to allow them to clean up.
This problem may also be caused by a refcounting bug in the
application or some element.

GThread-ERROR **: file /build/buildd/glib2.0-2.24.1/gthread/gthread-posix.c: line 171 (g_mutex_free_posix_impl): error 'Device or resource busy' during 'pthread_mutex_destroy ((pthread_mutex_t *) mutex)'
aborting...

we are using the following config in the Config properties filecamera part)

capture.device.Camera.flavor=presenter/source
capture.device.Camera.outputfile=Camera.mpg
capture.device.Camera.src=/dev/camera
capture.device.Camera.type=CUSTOM_VIDEO_SRC
capture.device.Camera.customProducer=v4l2src device=/dev/camera ! queue ! videorate ! video/x-raw-rgb ! ffmpegcolorspace ! queue
capture.device.Camera.buffer.bytes=1073741824

Lovemore Nalube
July 29, 2011, 7:45 AM
Edited

For us this was FIXED by the fix to MH-7593. It's in 1.1 and trunk.

Ramki
August 2, 2011, 10:03 AM

Hi Lovemore,

Thanks for your inputs. We tried with 1.1.X and the issue seems to have gone away.The earlier reported issue of Duration is also not coming up. Thanks for your inputs and good luck with your new assignement.

Assignee

Adam McKenzie

Reporter

Lovemore Nalube

Severity

Crash/Hang

Tags (folksonomy)

Components

Fix versions

Affects versions

Priority

Critical
Configure