distributed (worker) server does not start when http-proxy is needed

Steps to reproduce

Steps to reproduce:
1. for security reasons it is a good idea not to reveal servers directly to the internet that don't need a direct internet connection (as our server administrators told me) and so they decided that the distributed worker server should not have direct internet connection but use a proxy for internet requests. I had to define a bash variable $http_proxy and this is respected by all other tools (SVN, GIT, Maven), so that I could build matterhorn and the 3rd-party tools without any problem.
2. Only when I start the felix I get the problem that I can not build the felix-cache and I get the errors in the code snippet.
3. My M2_REPO is pointing to the right directory and I although tried -Dhttp.proxyHost= as suggested by the felix manual.
4. When the server is started everything should work fine because it is fully available in the intranet where the admin and engage servers are located too (worked just fine in 1.0)

Actual Results:

Expected Results:

Workaround (if any):

Activity

Show:
A
March 31, 2011, 9:00 PM

Micah, don't you have a similar setup?

Lars Kiesow
May 12, 2015, 2:26 PM

“Ο Θεός στο μηχάνημα έχει καθορίσει αυτόματα το πρόβλημα”

This ticket has been automatically resolved due to two years of inactivity. Please re-open if this issue is still relevant.

Assignee

Unassigned

Reporter

Rüdiger Rolf

Severity

Non Functioning

Tags (folksonomy)

Components

Fix versions

Affects versions

Priority

Critical
Configure