We're updating the issue view to help you get more done. 

FFMPEG gives error of 1 when trying to extract image files from VGA feed

Description

Sometimes, VGA video that is captured from the capture agent fails to segment. FFMPEG fails to extract segments in particular, here's a command that we have failing:

ffmpeg -strict inofficial -y -i /data2/opencast/workspace/mediapackage/3c995799-7220-4d95-b1c1-14310a2e428a/af97fe33-8d91-4166-ab47-fd4022c8eece/vga.mpg -ss 2435 -r 1 -vframes 1 -f image2 -pix_fmt rgb24 /data2/opencast/workspace/mediapackage/3c995799-7220-4d95-b1c1-14310a2e428a/af97fe33-8d91-4166-ab47-fd4022c8eece/vga_2435_7aabe258-39c7-43ae-9fe6-5cd943b2788a.2435.jpeg

This has happened with media from various capture agents, and does not seem deterministic. Once media has a problem, it is 100% reproducable with that media. The problem is with ffmpeg.

Potential work around: change the default workflow to not fail on error. Then lectures should process, albeit not completely correctly since they won't be segmented sometimes. This is being tested on U of S test stack.

Other workaround: reencoding the media to mkv (default settings) then reprocessing the media makes this problem go away (segmentation is successful).

Open issue: Unclear whether newer ffmpeg solves this issue.

Waiting on local team to make media available for further testing.

Steps to reproduce

None

Status

Assignee

Adam McKenzie

Reporter

Christopher Brooks

Criticality

None

Tags (folksonomy)

None

Components

Fix versions

Affects versions

1.2

Priority

Blocker