Uploaded image for project: 'Opencast'
  1. MH-8498

Matterhorn 1.3 capture agent does not install

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed and reviewed
    • Affects versions: 1.4.0, 1.3, 1.2.1
    • Fix versions: 1.4.0, 1.3, 1.2.1
    • Components: Legacy
    • Labels:
      None
    • Severity:
      Build Error
    • Steps to reproduce:
      Hide
      This seems odd to me because I'm sure this has been tested, but I cannot build the capture agent for matterhorn 1.3 on ubuntu 10.10 on the reference platform. When I run the installer script I get:

      Do you wish to use a custom software mirror instead of the Ubuntu defaults? [y/N] (? for help):
      Updating package repositories... Done
      All the necessary dependencies were already installed
      Found java at /usr/lib/jvm/java-6-sun
      Setting up java-6-sun as the default jvm... Done
      Downloading Felix... Uncompressing... tar: write error
      Done
      libjv4linfo.so already installed

      Which NTP server would you like to use? [ntp.ubuntu.com]:
      NTP server set to ntp.ubuntu.com
      Consider editing the file /etc/ntp.conf for manually changing the default NTP server or adding more servers to the list

      System information: 2.6.35-30-generic x86_64 GNU/Linux

      ./functions.sh: line 238: amp: command not found
      ./functions.sh: line 238: amp: command not found
      ./functions.sh: line 238: amp: command not found
      ./functions.sh: line 238: amp: command not found
      ./functions.sh: line 238: amp: command not found
      ./functions.sh: line 238: amp: command not found
      ./functions.sh: line 238: amp: command not found
      ./functions.sh: line 238: amp: command not found
      ./functions.sh: line 238: amp: command not found
      ./functions.sh: line 238: amp: command not found
      ./functions.sh: line 238: amp: command not found
      ./functions.sh: line 238: amp: command not found
      ./functions.sh: line 238: amp: command not found
      ./functions.sh: line 238: amp: command not found
      Please select from the following driver options available for this system for the Epiphan vga2usb device:
      1) <a
      2) class="autoindex_a"
      3) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.24.8.4-2.6.35-22-generic-i686.tbz">
      4) vga2usb-3.24.8.4-2.6.35-22-generic-i686.tbz
      5) <a
      6) class="autoindex_a"
      7) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.24.8.4-2.6.35-22-generic-pae.tbz">
      8) vga2usb-3.24.8.4-2.6.35-22-generic-pae.tbz
      9) <a
      10) class="autoindex_a"
      11) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.24.8.4-2.6.35-22-server-x86_64.tbz">
      12) vga2usb-3.24.8.4-2.6.35-22-server-x86_64.tbz
      13) <a
      14) class="autoindex_a"
      15) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.24.10.3-ubuntu_10.10_beta_2.6.35-22-generic-x86_64.tbz">
      16) vga2usb-3.24.10.3-ubuntu_10.10_beta_2.6.35-22-generic-x86_64.tbz
      17) <a
      18) class="autoindex_a"
      19) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.25.0.2-ubuntu-2.6.35-25-generic_x86_64.tbz">
      20) vga2usb-3.25.0.2-ubuntu-2.6.35-25-generic_x86_64.tbz
      21) <a
      22) class="autoindex_a"
      23) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.26.0.4-ubuntu-2.6.35-25-generic_i686.tbz">
      24) vga2usb-3.26.0.4-ubuntu-2.6.35-25-generic_i686.tbz
      25) <a
      26) class="autoindex_a"
      27) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.26.0.4-ubuntu-2.6.35-28-generic-pae.tbz">
      28) vga2usb-3.26.0.4-ubuntu-2.6.35-28-generic-pae.tbz
      29) <a
      30) class="autoindex_a"
      31) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.26.0.15-ubuntu-2.6.35-28-generic_x86_64.tbz">
      32) vga2usb-3.26.0.15-ubuntu-2.6.35-28-generic_x86_64.tbz
      33) <a
      34) class="autoindex_a"
      35) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.26.0.23-2.6.35.13-92.fc14.x86_64.tbz">
      36) vga2usb-3.26.0.23-2.6.35.13-92.fc14.x86_64.tbz
      37) <a
      38) class="autoindex_a"
      39) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.26.0.25-2.6.35.13-92.fc14.i686.PAE.tbz">
      40) vga2usb-3.26.0.25-2.6.35.13-92.fc14.i686.PAE.tbz
      41) <a
      42) class="autoindex_a"
      43) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.26.0.25-ubuntu-2.6.35-30-server_X86_64.tbz">
      44) vga2usb-3.26.0.25-ubuntu-2.6.35-30-server_X86_64.tbz
      45) <a
      46) class="autoindex_a"
      47) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.26.0.26-ubuntu-2.6.35-30-generic_X86_64.tbz">
      48) vga2usb-3.26.0.26-ubuntu-2.6.35-30-generic_X86_64.tbz
      49) <a
      50) class="autoindex_a"
      51) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.26.0.27-custom-2.6.35.14.i586.tbz">
      52) vga2usb-3.26.0.27-custom-2.6.35.14.i586.tbz
      53) <a
      54) class="autoindex_a"
      55) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.27.0.3-2.6.35.14-106.fc14.x86_64.tbz">
      56) vga2usb-3.27.0.3-2.6.35.14-106.fc14.x86_64.tbz
      57) Enter URL
      58) Do not need driver
      Selection (? for help):
      Show
      This seems odd to me because I'm sure this has been tested, but I cannot build the capture agent for matterhorn 1.3 on ubuntu 10.10 on the reference platform. When I run the installer script I get: Do you wish to use a custom software mirror instead of the Ubuntu defaults? [y/N] (? for help): Updating package repositories... Done All the necessary dependencies were already installed Found java at /usr/lib/jvm/java-6-sun Setting up java-6-sun as the default jvm... Done Downloading Felix... Uncompressing... tar: write error Done libjv4linfo.so already installed Which NTP server would you like to use? [ntp.ubuntu.com]: NTP server set to ntp.ubuntu.com Consider editing the file /etc/ntp.conf for manually changing the default NTP server or adding more servers to the list System information: 2.6.35-30-generic x86_64 GNU/Linux ./functions.sh: line 238: amp: command not found ./functions.sh: line 238: amp: command not found ./functions.sh: line 238: amp: command not found ./functions.sh: line 238: amp: command not found ./functions.sh: line 238: amp: command not found ./functions.sh: line 238: amp: command not found ./functions.sh: line 238: amp: command not found ./functions.sh: line 238: amp: command not found ./functions.sh: line 238: amp: command not found ./functions.sh: line 238: amp: command not found ./functions.sh: line 238: amp: command not found ./functions.sh: line 238: amp: command not found ./functions.sh: line 238: amp: command not found ./functions.sh: line 238: amp: command not found Please select from the following driver options available for this system for the Epiphan vga2usb device: 1) <a 2) class="autoindex_a" 3) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.24.8.4-2.6.35-22-generic-i686.tbz"> 4) vga2usb-3.24.8.4-2.6.35-22-generic-i686.tbz 5) <a 6) class="autoindex_a" 7) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.24.8.4-2.6.35-22-generic-pae.tbz"> 8) vga2usb-3.24.8.4-2.6.35-22-generic-pae.tbz 9) <a 10) class="autoindex_a" 11) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.24.8.4-2.6.35-22-server-x86_64.tbz"> 12) vga2usb-3.24.8.4-2.6.35-22-server-x86_64.tbz 13) <a 14) class="autoindex_a" 15) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.24.10.3-ubuntu_10.10_beta_2.6.35-22-generic-x86_64.tbz"> 16) vga2usb-3.24.10.3-ubuntu_10.10_beta_2.6.35-22-generic-x86_64.tbz 17) <a 18) class="autoindex_a" 19) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.25.0.2-ubuntu-2.6.35-25-generic_x86_64.tbz"> 20) vga2usb-3.25.0.2-ubuntu-2.6.35-25-generic_x86_64.tbz 21) <a 22) class="autoindex_a" 23) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.26.0.4-ubuntu-2.6.35-25-generic_i686.tbz"> 24) vga2usb-3.26.0.4-ubuntu-2.6.35-25-generic_i686.tbz 25) <a 26) class="autoindex_a" 27) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.26.0.4-ubuntu-2.6.35-28-generic-pae.tbz"> 28) vga2usb-3.26.0.4-ubuntu-2.6.35-28-generic-pae.tbz 29) <a 30) class="autoindex_a" 31) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.26.0.15-ubuntu-2.6.35-28-generic_x86_64.tbz"> 32) vga2usb-3.26.0.15-ubuntu-2.6.35-28-generic_x86_64.tbz 33) <a 34) class="autoindex_a" 35) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.26.0.23-2.6.35.13-92.fc14.x86_64.tbz"> 36) vga2usb-3.26.0.23-2.6.35.13-92.fc14.x86_64.tbz 37) <a 38) class="autoindex_a" 39) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.26.0.25-2.6.35.13-92.fc14.i686.PAE.tbz"> 40) vga2usb-3.26.0.25-2.6.35.13-92.fc14.i686.PAE.tbz 41) <a 42) class="autoindex_a" 43) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.26.0.25-ubuntu-2.6.35-30-server_X86_64.tbz"> 44) vga2usb-3.26.0.25-ubuntu-2.6.35-30-server_X86_64.tbz 45) <a 46) class="autoindex_a" 47) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.26.0.26-ubuntu-2.6.35-30-generic_X86_64.tbz"> 48) vga2usb-3.26.0.26-ubuntu-2.6.35-30-generic_X86_64.tbz 49) <a 50) class="autoindex_a" 51) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.26.0.27-custom-2.6.35.14.i586.tbz"> 52) vga2usb-3.26.0.27-custom-2.6.35.14.i586.tbz 53) <a 54) class="autoindex_a" 55) href="/downloads/linux/index.php?dir=&amp;file=vga2usb-3.27.0.3-2.6.35.14-106.fc14.x86_64.tbz"> 56) vga2usb-3.27.0.3-2.6.35.14-106.fc14.x86_64.tbz 57) Enter URL 58) Do not need driver Selection (? for help):

      TestRail: Results

        Attachments

          Activity

            People

            • Assignee:
              akm220 Adam McKenzie
              Reporter:
              felder@media.berkeley.edu Jonathan Felder
            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                TestRail: Cases