Reference Capture Agent crashes with 1.3 & 1.2

Steps to reproduce

Using the reference platform with ubuntu 10.10, every single capture agent we have tested with 1.3 and 1.2 eventually hangs requiring a reboot of the agent. There is no information in both the matterhorn and system logs.

When this occurs the machine is completely unresponsive including at the console, requiring a power cycle to come back online.

Activity

Show:
Jonathan Felder
April 27, 2012, 6:59 PM

This assumes of course that the crashes are related. Confidence monitoring at this time is known to not work. Let's get the agent to be stable without it enabled, and then concentrate on confidence monitoring.

Adam McKenzie
April 30, 2012, 3:47 PM

I tried to reproduce the error over the weekend on the capture agent here while GST_DEBUG was logging to a terminal. Unfortunately it didn't happen so I have scheduled another 6 x 1.5 hour captures to try and get it to fail while I log the gstreamer state.

Adam McKenzie
May 2, 2012, 5:07 PM

Adding debug log including GST DEBUG level 3 around time of crash. I also tried to capture GST DEBUG level 5 last night but the machine stopped responding to network connections (no pings, no ssh) so I was unable to retrieve the logs. I have started again with longer captures to try and exacerbate the problem.

I am also going to see if fixing the framerate on the epiphan card to 10 fps, different codecs and containers for the captures or disabling ingest will prevent the issue from occuring.

Adam McKenzie
November 1, 2012, 8:17 PM

Downloaded libglib from here:
http://ftp.acc.umu.se/pub/gnome/sources/glib/2.6/

Can't find a reference to the function g_slice_free. gstreamer java doesn't seem to have any references to this issue.

RĂ¼diger Rolf
December 10, 2013, 4:47 PM

I hope this is fixed for everybody with 1.4 somehow

Assignee

Adam McKenzie

Reporter

Jonathan Felder

Severity

Crash/Hang

Tags (folksonomy)

None

Components

Affects versions

Priority

Critical
Configure