Uploaded image for project: 'Opencast'
  1. MH-9100

REST: No input validatation errors on parameters

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Won't Fix
    • Affects versions: 1.4.0
    • Fix versions: 1.5.0
    • Components: Backend Software
    • Labels:
      None
    • Severity:
      Incorrect Documentation
    • Steps to reproduce:
      Hide
      Steps to reproduce:
      1. Go to http://testallinone.usask.ca:8080/docs.html?path=/analytics-rest
      2. Open the testing form for GET /users.json
      3. The form indicates that the date should be in format YYYYMMDD
      4. Put date in some other format (e.g. "3")
      5. Watch a 200 error come back
      6. I would have expected an error telling me that the date was not correctly specified
      Show
      Steps to reproduce: 1. Go to http://testallinone.usask.ca:8080/docs.html?path=/analytics-rest 2. Open the testing form for GET /users.json 3. The form indicates that the date should be in format YYYYMMDD 4. Put date in some other format (e.g. "3") 5. Watch a 200 error come back 6. I would have expected an error telling me that the date was not correctly specified
    • Tags (folksonomy):

      TestRail: Results

        Attachments

          Activity

            People

            • Assignee:
              akm220 Adam McKenzie
              Reporter:
              cab938 Christopher Brooks
            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                TestRail: Cases