Uploaded image for project: 'Opencast'
  1. MH-9290

Services Documentation links aren't linked to the right tenant in a multi tenant distributed environment

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed and reviewed
    • Affects versions: 1.4.0
    • Fix versions: 1.4.0
    • Labels:
      None
    • Severity:
      Non Functioning
    • Steps to reproduce:
      Hide
      Steps to reproduce:
      1. Set up multi tenant distributed environment with at least two tenants
      2. Go to the Welcome page and click on an service documentation link for both tenants
       
       Actual Results:
       At least for one tenant the documentation link is wrong (it shows to the default tenant or the server url)
       
       Expected Results:
       The links should link relative (the same host) to the docs
      Show
      Steps to reproduce: 1. Set up multi tenant distributed environment with at least two tenants 2. Go to the Welcome page and click on an service documentation link for both tenants    Actual Results:  At least for one tenant the documentation link is wrong (it shows to the default tenant or the server url)    Expected Results:  The links should link relative (the same host) to the docs
    • Tags (folksonomy):

      TestRail: Results

        Attachments

          Activity

            People

            • Assignee:
              lrohner Lukas Rohner
              Reporter:
              lrohner Lukas Rohner
            • Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                TestRail: Cases